Status
Get in touch
Back
Maintenance
Server Update
Completed 22 Oct at 09:20pm CEST.
Affected services
APP
API
Completed
Posted 22 Oct at 09:20pm CEST.
Started
Release 1.23.0
Posted 22 Oct at 09:10pm CEST.